Бесплатная проверка контрагентов в ФНС (общий модуль с алгоритмом). На примере выводим статус в список справочника контрагентов

Публикация № 755141

Разработка - Практика программирования

Проверка контрагентов ФНС Налоги Проверка ИНН Проверка КПП Проверка клиентов Проверка партнеров

124
Если вам интересно проверить контрагенте в ФНС, вам поможет данная публикация. Весь алгоритм работы строится на основе данных, полученных с сервиса http://npchk.nalog.ru совершенно бесплатно.

 

 Добрый день, Коллеги!

 

Возникла задача, понять и вытащить алгоритм проверки контрагентов в ФНС из типовой регламентированной отчетности. Алгоритм проверки на статус регистрации в ФНС и верность заполнения КПП. Задача развилась в идею вывести статус проверки ФНС в список справочника Контрагентов. Так же необходимо проверять статус ежедневно, чтобы держать базу с актуальными данными.

В современных конфигурациях (УТ11, КА2, ERP) данный алгоритм реализован на уровне типового решения, в старых конфигурациях в роде моей Комплексной Автоматизации 1.1 нет такой возможности, поэтому можно в путь пустить – творчество.

Программирование ведётся на конфигурации Комплексная Автоматизация 1.1.96.3 в режиме совместимости 8.2.13 (думаю, подойдёт к УТ10.3 и УПП),  обычные формы, но в управляемых как по мне было бы на много проще, но с другой стороны в тех конфигурациях велосипед уже есть.

 Что вы узнаете, прочитав данную статью: 

 

  1. Как получить данные из ФНС о контрагенте - http://npchk.nalog.ru
  2. Как вывести статус ФНС в табличную часть формы
  3. Создание в таблице формы колонки – картинки
  4. Как выделить цветом данные при выводе строк в таблице обычной формы и другое

Приступим.

Создаем новые объекты конфигурации

 

Сейчас все помешаны на расширениях, но не все могут этим воспользоваться, по этому представляю список доработок.

Общий список новых объектов:

  1. Общий модуль – «котПроверкаКонтрагентов»
  2. Картинка – «котСтатусыФНС»
  3. Регистр сведений «котКонтрагентыСтатусФНС»
  4. Регламентное задание «котЕжедневнаяПроверкаКонтрагентов»

 Общий модуль – «котПроверкаКонтрагентов» 

 

Создаем новый объект конфигурации – «общий модуль».

В моём случае название модуля – «котПроверкаКонтрагентов».

Настройки модуля:

 
 Программный код общего модуля

///////////////////////////////////////////////////////////////////////////////////
//	Данная разработка скачана из публикации:
//	//trueportal.ru/public/755141/
//	Котов Д.В. (//trueportal.ru/profile/564942/) 
//	Дата начала разработки - 30.01.2018
//	На основание бесплатного сервиса (http://npchk.nalog.ru) 
//	Важно понимать, что на данный момент сервис работает в тестовом режиме
///////////////////////////////////////////////////////////////////////////////////

Процедура ПроверкаКонтрагентов() Экспорт
	ДанныеПолучены = ЛОЖЬ;
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	СтатусыФНС.Контрагент
	|ИЗ
	|	РегистрСведений.котКонтрагентыСтатусФНС КАК СтатусыФНС
	|ГДЕ
	|	СтатусыФНС.Статус = ""1""";	
	Результат = Запрос.Выполнить();
	Если Результат.Пустой() Тогда
		УстановитьФильтр = ЛОЖЬ;
	Иначе
		УстановитьФильтр = ИСТИНА;
		КонтрагентыКоторыеНеДействуют = Результат.Выгрузить();
	КонецЕсли;
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	Контрагенты.Ссылка КАК Контрагент,
	|	Контрагенты.ИНН,
	|	Контрагенты.КПП,
	|	ВЫРАЗИТЬ("""" КАК СТРОКА(100)) КАК Состояние,
	|	&ТекущайДата КАК Дата
	|ИЗ
	|	Справочник.Контрагенты КАК Контрагенты
	|ГДЕ
	|	Контрагенты.ИНН <> """"" +
	?(УстановитьФильтр,"И НЕ Контрагенты.Ссылка В(&ГруппаКонтрагентов)","");
	Запрос.УстановитьПараметр("ТекущайДата",ТекущаяДата());
	Запрос.УстановитьПараметр("ГруппаКонтрагентов",КонтрагентыКоторыеНеДействуют);
	ДанныеКонтрагента = Запрос.Выполнить().Выгрузить();		
	ПолучитьРезультатПроверкиВебСервисом(ДанныеКонтрагента,ДанныеПолучены);
	Если ДанныеПолучены Тогда
		Для Каждого Строка Из ДанныеКонтрагента Цикл		
			НаборЗаписей = РегистрыСведений.котКонтрагентыСтатусФНС.СоздатьНаборЗаписей();
			НаборЗаписей.Отбор.Контрагент.Установить(Строка.Контрагент); 
			НаборЗаписей.Прочитать();
			Если НаборЗаписей.Количество() > 0 Тогда
				ЗаписьТекущая = НаборЗаписей.Получить(0);
				Пропускать = ЗаписьТекущая.Статус = "1"; 
			Иначе
				Пропускать = ЛОЖЬ;
			КонецЕсли;
			Если НЕ Пропускать Тогда
				НаборЗаписей.Очистить();
				НаборЗаписей.Записать();
				НоваяЗапись = НаборЗаписей.Добавить(); 		   
				НоваяЗапись.Контрагент = Строка.Контрагент; 
				НоваяЗапись.Статус = Строка.Состояние; 
				НаборЗаписей.Записать(ИСТИНА); 		
			КонецЕслИ;					
		КонецЦикла;
	КонецЕсли;
КонецПроцедуры

Функция ПроверитьКонтрагентаПоСсылке(Контрагент,Дата = Неопределено) Экспорт
	Если Дата = Неопределено Тогда
		Дата = ТекущаяДата();	
	КонецЕсли;
	Если Контрагент.ИНН <> "" Тогда 
		ДанныеПолучены = ЛОЖЬ;
		ДанныеКонтрагента = Новый ТаблицаЗначений;
		ДанныеКонтрагента.Колонки.Добавить("Контрагент", 	Новый ОписаниеТипов("СправочникСсылка.Контрагенты"));
		ДанныеКонтрагента.Колонки.Добавить("ИНН", 			Новый ОписаниеТипов("Строка",,Новый КвалификаторыСтроки(12)));
		ДанныеКонтрагента.Колонки.Добавить("КПП", 			Новый ОписаниеТипов("Строка",,Новый КвалификаторыСтроки(9)));
		ДанныеКонтрагента.Колонки.Добавить("Дата", 			Новый ОписаниеТипов("Дата",,,Новый КвалификаторыДаты(ЧастиДаты.Дата)));
		ДанныеКонтрагента.Колонки.Добавить("Состояние", 	Новый ОписаниеТипов("Строка",,Новый КвалификаторыСтроки(100)));
		ТекущийКонтрагент = ДанныеКонтрагента.Добавить();
		ТекущийКонтрагент.Контрагент = Контрагент;
		ТекущийКонтрагент.ИНН = Контрагент.ИНН;
		ТекущийКонтрагент.КПП = Контрагент.КПП;
		ТекущийКонтрагент.Дата = Дата;
		ПолучитьРезультатПроверкиВебСервисом(ДанныеКонтрагента,ДанныеПолучены);
		Если ДанныеПолучены Тогда
			Ответ = ДанныеКонтрагента[0].Состояние;	
			СостояниеФНС = СостояниеНаОсновеОтветаСервиса(Контрагент,Ответ);
		Иначе
			СостояниеФНС = "Сервер ФНС - не доступен, попробуйте позже";
		КонецЕсли;
	Иначе
		СостояниеФНС = "У контрагента не заполнен ИНН";
	КонецЕсли;	
	Возврат СостояниеФНС;
КонецФункции

Процедура ПолучитьРезультатПроверкиВебСервисом(ДанныеКонтрагентов, ЕстьДоступКВебСервисуФНС)	
	КоличествоКонтрагентов = ДанныеКонтрагентов.Количество();
	ЕстьДоступКВебСервисуФНС = ЕстьДоступКВебСервисуФНС();
	Если КоличествоКонтрагентов = 0 
		ИЛИ НЕ ЕстьДоступКВебСервисуФНС 
		Тогда
		Возврат;
	КонецЕсли;		
	Прокси = ПолучитьWSПрокси();	
	ПространствоИмен = "http://ws.unisoft/FNSNDSCAWS2/Request";	
	РазмерПорции = 10000; //возможно ограничения, в типовой так написано, максимум в запросе 10 000 контрагентов	
	КоличествоЗапросов = ?(КоличествоКонтрагентов % РазмерПорции = 0, КоличествоКонтрагентов / РазмерПорции, Цел(КоличествоКонтрагентов / РазмерПорции) + 1);		
	Для НомерПорции = 1 По КоличествоЗапросов Цикл 		
		МинимальныйНомерКонтрагента 	= Мин(РазмерПорции * (НомерПорции - 1), КоличествоКонтрагентов);
		МаксимальныйНомерКонтрагента 	= Мин(РазмерПорции * НомерПорции, КоличествоКонтрагентов) - 1;
		WSЗапрос = Прокси.ФабрикаXDTO.Создать(Прокси.ФабрикаXDTO.Тип(ПространствоИмен, "NdsRequest2"));		
		Для ИндексТекущегоКонтрагента = МинимальныйНомерКонтрагента По МаксимальныйНомерКонтрагента Цикл			
			ДанныеКонтрагента = ДанныеКонтрагентов[ИндексТекущегоКонтрагента];
			ДобавитьКонтрагентаВЗапросКСервису(WSЗапрос, Прокси, ПространствоИмен, ДанныеКонтрагента); 			
		КонецЦикла;		
		Если WSЗапрос.NP.Количество() = 0 Тогда
			Продолжить;
		КонецЕсли;	
		ЕстьДоступКВебСервисуФНС = ЕстьДоступКВебСервисуФНС();
		Попытка
			NdsResponse = Прокси.NdsRequest2(WSЗапрос);
		Исключение		
			ЗаписьЖурналаРегистрации("Проверка контрагентов.NdsRequest",УровеньЖурналаРегистрации.Ошибка,,, ПодробноеПредставлениеОшибки(ИнформацияОбОшибке()));			
			NdsResponse = Неопределено;	// Страхуемся от ошибки "Timeout wаs reached".
		КонецПопытки;		
		Если NdsResponse <> Неопределено Тогда
			ОбработатьОтветСервиса(NdsResponse, ДанныеКонтрагентов, МинимальныйНомерКонтрагента, МаксимальныйНомерКонтрагента);				
		КонецЕсли;		
	КонецЦикла; 	
КонецПроцедуры

Процедура ДобавитьКонтрагентаВЗапросКСервису(WSЗапрос, Прокси, ПространствоИмен, ДанныеКонтрагента)	
	Попытка	
		WSКонтрагент = Прокси.ФабрикаXDTO.Создать(Прокси.ФабрикаXDTO.Тип(ПространствоИмен, "NdsRequest2_NP"));	
		WSКонтрагент.INN = ДанныеКонтрагента.ИНН;	
		//ИП - проверяются БЕЗ указания КПП, иначе вернётся ошибка с кодом "10"
		Если ДанныеКонтрагента.Контрагент.ЮрФизЛицо = Перечисления.ЮрФизЛицо.ЮрЛицо Тогда
			КонтрагентЮР = ИСТИНА;
		Иначе
			КонтрагентЮР = ЛОЖЬ;
		КонецЕсли;
		Если ЗначениеЗаполнено(ДанныеКонтрагента.КПП) И КонтрагентЮР Тогда
			WSКонтрагент.KPP = ДанныеКонтрагента.КПП;
		Иначе
			WSКонтрагент.KPP = "";
		КонецЕсли;
		Если ЗначениеЗаполнено(ДанныеКонтрагента.Дата)Тогда
			WSКонтрагент.DT = ДатаСтрокой(ДанныеКонтрагента.Дата);
		КонецЕсли;
		WSЗапрос.NP.Добавить(WSКонтрагент);
	Исключение		
		ФиксацияОшибкиВЖурналеРегистрации("Проверка контрагентов. Ошибка в заполнение запроса по контрагенту код: " +
		ДанныеКонтрагента.Контрагент.Код,ИнформацияОбОшибке());
		ДанныеКонтрагента.Состояние = "W"; //Ошибка в данных		
	КонецПопытки; 				
КонецПроцедуры

Процедура ОбработатьОтветСервиса(NdsResponse, ДанныеКонтрагентовДляПроверкиСервисом, МинимальныйНомерКонтрагента, МаксимальныйНомерКонтрагента)	
	ИндексТекущегоОтвета = 0;
	Для ИндексТекущегоКонтрагента = МинимальныйНомерКонтрагента По МаксимальныйНомерКонтрагента Цикл 
		ДанныеКонтрагента = ДанныеКонтрагентовДляПроверкиСервисом[ИндексТекущегоКонтрагента];
		Попытка
			ОтветПоКонтрагенту 			= NdsResponse.NP[ИндексТекущегоОтвета];
			СостояниеВОтвете 			= ОтветПоКонтрагенту.State;
			ДанныеКонтрагента.Состояние = СостояниеВОтвете;			
		Исключение		
			ФиксацияОшибкиВЖурналеРегистрации("Проверка контрагентов.Обработка ответа от веб-сервиса",ИнформацияОбОшибке());		
		КонецПопытки;			
		ИндексТекущегоОтвета = ИндексТекущегоОтвета + 1;		
	КонецЦикла;				
КонецПроцедуры

Функция ЕстьДоступКВебСервисуФНС()	
	Возврат ПолучитьWSПрокси() <> Неопределено;	
КонецФункции

Функция ПолучитьWSПрокси() 	
	WSПрокси = Неопределено;
	Попытка
		WSПрокси = ОбщегоНазначения.WSПрокси(
		"http://npchk.nalog.ru/FNSNDSCAWS_2?wsdl",
		"http://ws.unisoft",
		"FNSNDSCAWS2",
		"FNSNDSCAWS2_Port",
		Неопределено,
		Неопределено,
		120);
	Исключение
		ФиксацияОшибкиВЖурналеРегистрации("Проверка контрагентов. Ошибка подключени WSПрокси.",ИнформацияОбОшибке())			
	КонецПопытки;
	Возврат WSПрокси;	
КонецФункции

Функция СостояниеНаОсновеОтветаСервиса(ДанныеКонтрагента, Ответ) Экспорт	
	Если Ответ = "0" Тогда
		Состояние = "Контрагент есть в базе ФНС";
	ИначеЕсли Ответ = "1" Тогда
		Если СтрДлина(ДанныеКонтрагента.ИНН) = 12 Тогда
			Состояние = "Не действует";
		Иначе
			Состояние = "Не действует или изменен КПП";
		КонецЕсли;
	ИначеЕсли Ответ = "3" Тогда
		Состояние = "КПП не соответствует данным базы ФНС";
	ИначеЕсли Ответ = "4" Тогда
		Состояние = "Контрагент отсутствует в базе ФНС";
	ИначеЕсли Ответ = "5" ИЛИ Ответ = "6" ИЛИ Ответ = "8" Тогда
		Состояние = "Ошибка. Некорректный ИНН";
	ИначеЕсли Ответ = "7" ИЛИ Ответ = "9" Тогда
		Состояние = "Ошибка. Некорректный КПП";
	ИначеЕсли Ответ = "11" ИЛИ Ответ = "12" Тогда
		Состояние = "Ошибка. Некорректная дата проверки";
	ИначеЕсли Ответ = "10" Тогда
		Состояние = "Ошибка. ИП заведено как юридическое лицо";
	ИначеЕсли Ответ = "W" Тогда
		Состояние = "Возникла ошибка заполнения данных контрагента";
	КонецЕсли;		
	Возврат Состояние;	
КонецФункции

Функция НомерКартинкиСтатуса(Статус) Экспорт	
	Если Статус = "0" Тогда
		СтатусКартинка = 3;
	ИначеЕсли Статус = "1" Тогда
		СтатусКартинка = 2;
	Иначе
		СтатусКартинка = 1;
	КонецЕсли;		
	Возврат СтатусКартинка;	
КонецФункции

Функция ДатаСтрокой(Дата)	
	Результат = Неопределено;
	Если ТипЗнч(Дата) = Тип("Строка") Тогда 
		Результат = Дата;
	ИначеЕсли ТипЗнч(Дата) = Тип("Дата") Тогда 
		Результат = Формат(Дата, "ДФ=dd.MM.yyyy");
	КонецЕсли;	
	Возврат Результат;	
КонецФункции

Процедура ФиксацияОшибкиВЖурналеРегистрации(ИмяСобытия,ИнформацияОбОшибке)
	ЗаписьЖурналаРегистрации(НСтр("ru = '"+ИмяСобытия+"'"),УровеньЖурналаРегистрации.Ошибка,,,ПодробноеПредставлениеОшибки(ИнформацияОбОшибке));	
КонецПроцедуры

Процедура ОчиститьРегистрСведенийСДаннымиПроверки() Экспорт
	НаборЗаписей = РегистрыСведений.котКонтрагентыСтатусФНС.СоздатьНаборЗаписей();
	НаборЗаписей.Записать();
КонецПроцедуры

 

 Картинка – «котСтатусыФНС» 

 

Создаем новый объект – Общие картинки, название «котСтатусыФНС».

Подгружаем картинку -         <<< скачайте

Описание иконок статуса ФНС:

 Регистр сведений – «котКонтрагентыСтатусФНС» 

 

Создаем регистр сведений – «котКонтрагентыСтатусФНС»

Основные

Периодичность: Непериодический

Режим записи: Независимый

Данные

Измерение – Контрагент – тип СправочникСсылка.Контрагенты

Ресурс – Статус – тип Строка (150)

Настройка прав за вами!

 Регламентное задание «котЕжедневнаяПроверкаКонтрагентов» 

 

Создаем объект конфигурации регламентное задание «котЕжедневнаяПроверкаКонтрагентов».

Имя метода – тыкаем по «лупе» и автоматически создаем процедуру в нашем модуле «котПроверкаКонтрагентов».

В созданную процедуру дописываем код вызова процедуры проверки контрагентов:

Процедура котЕжедневнаяПроверкаКонтрагентов() Экспорт
	ПроверкаКонтрагентов();
КонецПроцедуры

                                                                               

Доработка объектов конфигурации

 

Мы определились с новыми объектами, переходим к изменению объектов конфигурации.

Общий список изменений:

  1. Справочник – «Контрагенты», ФормаСписка
  2. Справочник – «Контрагенты», ФормаВыбора

Необходимо убедиться, что выше перечисленные объекты сняты с «замка».

 Общий принцип доработки обоих форм (повторяем и для ФормаСписка и для ФормаВыбора) 

 

Необходимо создать колонку «котСтатусФНС» в таблице формы – «СправочникСписок».

 ВНИМАНИЕ!  Не забывайте что 1С поддерживает копирование, да же колонок из одной формы в другую.

Добавляем колонку и настраиваем значение свойств:

Так же задаем свойства полю ввода:

Находим процедуру «ПриВыводеСтроки» событий таблицы формы «СправочникСписок» и проваливаемся в неё если есть или проваливаемся чтобы создать искомую:

В процедуру добавляем код:

	//Котов Д.В. +++ 31.01.2018
	//Так же можно выделять цветом всю строку целиком, тут ваш полёт фантазии не ограничен
	Если НЕ ОформлениеСтроки.ДанныеСтроки.ЭтоГруппа Тогда
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьТекст = ЛОЖЬ;
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьФлажок = ЛОЖЬ;
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьКартинку = ИСТИНА;		
		Запрос = Новый Запрос;
		Запрос.Текст = "ВЫБРАТЬ
		|	котКонтрагентыСтатусФНС.Статус
		|ИЗ
		|	РегистрСведений.котКонтрагентыСтатусФНС КАК котКонтрагентыСтатусФНС
		|ГДЕ
		|	котКонтрагентыСтатусФНС.Контрагент = &Контрагент";	
		Запрос.УстановитьПараметр("Контрагент", ОформлениеСтроки.ДанныеСтроки.Ссылка);	
		Результат = Запрос.Выполнить();	
		Если Результат.Пустой() Тогда
			ОформлениеСтроки.Ячейки.котСтатусФНС.ИндексКартинки = 0;
		Иначе
			Выборка = Результат.Выбрать();
			Выборка.Следующий();		
			ОформлениеСтроки.Ячейки.котСтатусФНС.ИндексКартинки = котПроверкаКонтрагентов.НомерКартинкиСтатуса(Выборка.Статус); 
		КонецЕсли;
	КонецЕсли;
	//Котов Д.В. --- 31.01.2018

Проверяем работу

 

Для проверки работы, так удобнее, нам потребуется простая обработка с двумя кнопками.

Одна "Проверить контрагентов" будет вызывать процедуру – 

котПроверкаКонтрагентов. котЕжедневнаяПроверкаКонтрагентов();

Вторая кнопка вызовет процедуру –

котПроверкаКонтрагентов. ОчиститьРегистрСведенийСДаннымиПроверки();

Запустив обработку, нажимаем кнопку «Проверить контрагентов» и ждём.

 ВНИМАНИЕ!  Выполнение кода может ни к чему не привести, так как сервер ФНС не стабилен! Может откликнуться только со 2 раза… 10…100 раза… или сразу. По этому если регистр сведений не заполнился, жмем ещё раз!

Когда видим, что регистр сведений успешно заполнен:

Открываем смело справочник контрагентов и видим радостную картинку:

Запускаем регламентное задание

 

Для запуска регламентного задания, вам потребуется - КонсольЗаданий:

Можно скачать с ИТС: https://its.1c.ru/db/metod8dev/content/3752/hdoc

Так же расширенная версия консоли заданий включена в "Инструменты разработчика": http://devtool1c.ucoz.ru/

Настраиваем задание, регулярность выполнение ваше пожелания:

Резюме

 

Функционал можно расширить, в моём случае помимо фиксации статуса ФНС будет так же фиксация в разрезе документов реализации и заказов, чтобы можно было подсвечивать заказы и реализации как в новых конфигурациях в зависимости от проблемности контрагента. Под проблемностью мы конечно понимает либо нет регистрации в ФНС или содержит ошибки КПП.

Кто внимательный то мог заметить, что в модуле есть функция ПроверитьКонтрагентаПоСсылке(Контрагент,Дата = Неопределено), данная функция позволяет по ссылке контрагента проверить его статус в ФНС, ответ ввиде строковой расшифровки, успешная – «Контрагент есть в базе ФНС». Если дата не указана, проверка производиться на текущую дату, иначе можно посмотреть допустим на момент сделки.

Так же вы можете расшифровать статус ФНС (он числовой от 0 до 12) с помощью функции СостояниеНаОсновеОтветаСервиса(ДанныеКонтрагента, Ответ).

Не забывайте важный момент – сервис работает в тестовом режиме – а это может быть всё что угодно!

Удачного кодинга!

 

 

Посткриптум

 

Наверное многие так же как я в режиме мистической совместимости 8.2.13 ведёт разработку и на управляемых формах. Так вот, всё, что я описывал в пункте «Доработка объектов конфигурации», намного проще реализуется не в таблице обычной формы, а в динамическом списке управляемой формы. Смотрите сами как легко (без кода почти) добавить колонку со статусом.

  1. Корректируем запрос добавив наш статус:

ВЫБРАТЬ
	Контрагенты.Код,
	Контрагенты.Наименование,
	Контрагенты.ИНН,
	Контрагенты.КПП,
	Контрагенты.НаименованиеПолное,
	ВЫБОР
		КОГДА котКонтрагентыСтатусФНС.Статус ЕСТЬ NULL
			ТОГДА 0
		КОГДА котКонтрагентыСтатусФНС.Статус = "0"
			ТОГДА 3
		КОГДА котКонтрагентыСтатусФНС.Статус = "1"
			ТОГДА 2
		ИНАЧЕ 1
	КОНЕЦ КАК ФНС
ИЗ
	Справочник.Контрагенты КАК Контрагенты
		ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.котКонтрагентыСтатусФНС КАК котКонтрагентыСтатусФНС
		ПО Контрагенты.Ссылка = котКонтрагентыСтатусФНС.Контрагент
  1. Перетаскиваем новую колонку в таблицу на форме и настраиваем ряд свойств:

Результат работы:

Как по мне динамический список и СКД это просто магия и песня!

Предлагаю вашему внимаю мою процедуру программного создания динамического списка:

 //trueportal.ru/public/728597/

 Описание файлов к публикации 

 

Зачем тут файлы? Ну возможно, кому-то лень всё это повторить и проще накатить сравнением объединением готовый продукт, который легко ставится на КА 1.1, по всей видимости встанет и на УПП 1.3, УТ 10.3.

А также это единственная материальная благодарность автора, от которой не откажусь ;)

ПроверкаКонтрагентов.cf – готовый CF, содержащий рабочий алгоритм, описанный в данный статье, устанавливается сравнением объединением (кто умеет).

котИмитацияРаботыРегламетногоЗадания.epf – обработка, описанная выше.

котКонтрагенты.epf – обработка содержит пример работы динамического списка из посткриптума.

124

Скачать файлы

Наименование Файл Версия Размер
ПроверкаКонтрагентов.cf (Подсистема "Проверка контрагента" (готовый алгоритм))
.cf 56,70Kb
12.09.18
48
.cf 56,70Kb 48 Скачать
котИмитацияРаботыРегламетногоЗадания.epf (Обработка имитация запуска регламентного задания)
.epf 5,95Kb
01.02.18
6
.epf 5,95Kb 6 Скачать
котКонтрагенты.epf (Пример динамического списка)
.epf 6,91Kb
01.02.18
9
.epf 6,91Kb 9 Скачать

Специальные предложения

Лучшие комментарии
31. rpgshnik 1775 09.02.18 11:59 Сейчас в теме
Статью уже править не буду, но у себя добавил, советую и вам всем кто заинтересовался добавить ;)
Зачем это? Комментарии к публикации можете почитать и поймёте что почти три дня сервис лежал.
Сервис не стабильный - по этому лучше держать актуальные данные или что бы он отключался и пользователь понимал - что данной проверке нельзя доверять.

1. Константу - тип булево - включить/выключить функционал проверки контрагентов в ФНС
2. Константу - тип дата - содержит дату актуальной проверки

В формы которые я использую в справочнике Контрагентов я добавил в модуль формы переменную:

Перем ВыводитьСтатусФНС;


Затем я подвязал на открытие форм, процедуре ПриОткрытие

	ЭлементыФормы.СправочникСписок.Колонки.котСтатусФНС.Видимость = Константы.котПроверкаКонтрагентовВключен.Получить();
	ВыводитьСтатусФНС = НачалоДня(Константы.котПроверкаКонтрагентовФНСДатаПроверки.Получить()) = НачалоДня(ТекущаяДата());


Затем ещё скорректировал код при выводе строки:

	//Котов Д.В. +++ 31.01.2018
	//Так же можно выделять цветом всю строку целиком, тут ваш полёт фантазии не ограничен
	Если НЕ ОформлениеСтроки.ДанныеСтроки.ЭтоГруппа Тогда
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьТекст = ЛОЖЬ;
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьФлажок = ЛОЖЬ;
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьКартинку = ИСТИНА;
		Если ВыводитьСтатусФНС Тогда	//Котов Д.В. +++ 09.02.2018		
			Запрос = Новый Запрос;
			Запрос.Текст = "ВЫБРАТЬ
			|	котКонтрагентыСтатусФНС.Статус
			|ИЗ
			|	РегистрСведений.котКонтрагентыСтатусФНС КАК котКонтрагентыСтатусФНС
			|ГДЕ
			|	котКонтрагентыСтатусФНС.Контрагент = &Контрагент";	
			Запрос.УстановитьПараметр("Контрагент", ОформлениеСтроки.ДанныеСтроки.Ссылка);	
			Результат = Запрос.Выполнить();	
			Если Результат.Пустой() Тогда
				ОформлениеСтроки.Ячейки.котСтатусФНС.ИндексКартинки = 0;
			Иначе
				Выборка = Результат.Выбрать();
				Выборка.Следующий();		
				ОформлениеСтроки.Ячейки.котСтатусФНС.ИндексКартинки = котПроверкаКонтрагентов.НомерКартинкиСтатуса(Выборка.Статус); 
			КонецЕсли;
		Иначе
			ОформлениеСтроки.Ячейки.бгбСтатусФНС.ИндексКартинки = 0;	//Котов Д.В. +++ 09.02.2018
		КонецЕсли;
	КонецЕсли;
	//Котов Д.В. --- 31.01.2018
Показать


Результат данных действий простой:

1. Мы можем отключить алгоритм проверки статусов контрагентов в режиме предприятия онлайн!
2. Мы будем иметь только актуальные статусы, если каким-то образом проверка не прошла - тогда все иконки статусов будут "серыми".

Доработки общего модуля:

Ещё я добавил в общий модуль проверки - регламентной процедуры следующий код в самом начале:

Процедура котЕжедневнаяПроверкаКонтрагентов() Экспорт
	//Котов Д.В. +++ 09.02.2018 
	//Если механизм проверки не включен, тогда и проверять не нужно. Чтобы регламетной задание не отключать ;)
	Если НЕ Константы.котПроверкаКонтрагентовВключен.Получить() Тогда Возврат; КонецЕсли;
	//Решено актуализировать один раз на текущую дату, смотрите как вам удобнее.	
	Если НачалоДня(Константы.котПроверкаКонтрагентовФНСДатаПроверки.Получить()) = НачалоДня(ТекущаяДата()) Тогда Возврат; КонецЕсли;
	//Котов Д.В. --- 09.02.2018
	ПроверкаКонтрагентов();
КонецПроцедуры
Показать


А процедуре по проверке контрагентов "ПроверкаКонтрагентов()" добавил строчки по записи даты в константу:
Процедура ПроверкаКонтрагентов() Экспорт
	ДанныеПолучены = ЛОЖЬ;
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	СтатусыФНС.Контрагент
	|ИЗ
	|	РегистрСведений.котКонтрагентыСтатусФНС КАК СтатусыФНС
	|ГДЕ
	|	СтатусыФНС.Статус = ""1""";	
	Результат = Запрос.Выполнить();
	Если Результат.Пустой() Тогда
		УстановитьФильтр = ЛОЖЬ;
	Иначе
		УстановитьФильтр = ИСТИНА;
		КонтрагентыКоторыеНеДействуют = Результат.Выгрузить();
	КонецЕсли;
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	Контрагенты.Ссылка КАК Контрагент,
	|	Контрагенты.ИНН,
	|	Контрагенты.КПП,
	|	ВЫРАЗИТЬ("""" КАК СТРОКА(100)) КАК Состояние,
	|	&ТекущайДата КАК Дата
	|ИЗ
	|	Справочник.Контрагенты КАК Контрагенты
	|ГДЕ
	|	Контрагенты.ИНН <> """"" +
	?(УстановитьФильтр,"И НЕ Контрагенты.Ссылка В(&ГруппаКонтрагентов)","");
	Запрос.УстановитьПараметр("ТекущайДата",ТекущаяДата());
	Запрос.УстановитьПараметр("ГруппаКонтрагентов",КонтрагентыКоторыеНеДействуют);
	ДанныеКонтрагента = Запрос.Выполнить().Выгрузить();		
	ПолучитьРезультатПроверкиВебСервисом(ДанныеКонтрагента,ДанныеПолучены);
	Если ДанныеПолучены Тогда
		Для Каждого Строка Из ДанныеКонтрагента Цикл		
			НаборЗаписей = РегистрыСведений.котКонтрагентыСтатусФНС.СоздатьНаборЗаписей();
			НаборЗаписей.Отбор.Контрагент.Установить(Строка.Контрагент); 
			НаборЗаписей.Прочитать();
			Если НаборЗаписей.Количество() > 0 Тогда
				ЗаписьТекущая = НаборЗаписей.Получить(0);
				Пропускать = ЗаписьТекущая.Статус = "1"; 
			Иначе
				Пропускать = ЛОЖЬ;
			КонецЕсли;
			Если НЕ Пропускать Тогда
				НаборЗаписей.Очистить();
				НаборЗаписей.Записать();
				НоваяЗапись = НаборЗаписей.Добавить(); 		   
				НоваяЗапись.Контрагент = Строка.Контрагент; 
				НоваяЗапись.Статус = Строка.Состояние; 
				НаборЗаписей.Записать(ИСТИНА); 		
			КонецЕслИ;					
		КонецЦикла;
		//Котов Д.В. +++ 09.02.2018 
		ДатаПроверки = Константы.схпПроверкаКонтрагентовФНСДатаПроверки;
		ДатаПроверки.Установить(ТекущаяДата());
		//Котов Д.В. --- 09.02.2018
	КонецЕсли;
КонецПроцедуры
Показать
Остальные комментарии
Избранное Подписка Сортировка: Древо
1. smirnov.es 16 01.02.18 11:12 Сейчас в теме
Кот проверка контрагентов
Прикрепленные файлы:
the1; LordKim; madonov; sckif; ice-net; корум; bserge88; siddy; Lo1jke; jif; pavlov_dv; Артано; Interrupted; rpgshnik; +14 Ответить
2. pm74 135 01.02.18 12:24 Сейчас в теме
(0) оформление по "феншую" ))

добавим в "копилку" , вдруг пригодиться
denismal; Артано; rpgshnik; +3 Ответить
3. Поручик 4332 01.02.18 12:42 Сейчас в теме
Пригодится
madonov; корум; rpgshnik; +3 Ответить
4. fr13 01.02.18 22:26 Сейчас в теме
небольшое замечание - у Вас идет обращение к БД в процедуре при ВыводеСтроки. Запросов будет меньше, если поместить это в ПриПолученииДанных
корум; CSiER; rpgshnik; +3 Ответить
8. rpgshnik 1775 02.02.18 02:35 Сейчас в теме
(4) спасибо, я подумаю над этим.
5. triviumfan 12 01.02.18 22:47 Сейчас в теме
Странно, ведь было какое-то ограничение на количество запросов или ещё что, поэтому сервис вскоре стал платным (как и заполнение по ИНН). Далее 1с его в подписку запихало, что не удивительно. А теперь опять что ли бесплатно будет?:)
6. triviumfan 12 02.02.18 00:23 Сейчас в теме
У меня постоянно ответ "W", то бишь
Возникла ошибка заполнения данных контрагента
7. triviumfan 12 02.02.18 01:05 Сейчас в теме
(6) Извиняюсь, проверка на ЮрЛицо у меня не проходила, т.к. метаданные разные. Исправил.
Но заметил ещё кое-что - возвращаемый статус отличается от того, что сам сайт возвращает.
9. rpgshnik 1775 02.02.18 02:45 Сейчас в теме
(7) а какой именно статус возвращает?
12. triviumfan 12 02.02.18 09:48 Сейчас в теме
(9) Да я на ночь глядя не разобрался. Сейчас вижу, что все корректно, просто вы перефразировали статусы.
К примеру, статус 3 на сайте возвращает "Налогоплательщик с указанным ИНН зарегистрирован в ЕГРН", а у вас "КПП не соответствует данным базы ФНС".
Хотя в файле описании вообще "Налогоплательщик с указанным ИНН зарегистрирован в ЕГРН, КПП не соответствует ИНН или не указан*.
Вот я и запутался :)
Прикрепленные файлы:
Описание.doc
10. IsiKosta 721 02.02.18 06:00 Сейчас в теме
Что значат иконки в колонке "ФНС" ? (Какие статусы какой картинке соответствуют)
11. rpgshnik 1775 02.02.18 06:06 Сейчас в теме
13. vasilev2015 1503 02.02.18 11:14 Сейчас в теме
Статья симпатичная, но сам сервис плоховат. Иногда не отвечает, возвращает только статус. Пробовал использовать платный сервис, встроенный в бухгалтерию 3.0 - он еще хуже. Юридический адрес нашей фирмы возвращает с ошибкой. Заплаченные 4 тр сервис съел за неделю, хотя должно было хватить на 6 месяцев. Нет бочки меда без ложки дегтя.
rpgshnik; +1 Ответить
14. rpgshnik 1775 02.02.18 11:44 Сейчас в теме
(13) сервис плоховат, но он пока обрабатывает пакетами контрагентов и более менее правдивый. Остальные все платные... А так согласен, в статье то же писал, что может с 10-ого раза ответить))
15. brrart 24 03.02.18 08:51 Сейчас в теме
(14) Это уж точно. что более менее. Не все данные правдивы. У нас реализована проверка через этот сервис, но пока тоже в тестовом режиме. Хотим в автоматическом режиме отказывать в отгрузках клиентам, не прошедшим данную проверку. Но пока не можем, потому как попадаются такие, которые эту проверку не проходят, а сервис той-же ФНС https://egrul.nalog.ru/ говорит что с ними всё ок. Смотрим в сторону Контура с это API.
rpgshnik; +1 Ответить
16. rpgshnik 1775 03.02.18 13:02 Сейчас в теме
17. webester 29 04.02.18 18:56 Сейчас в теме
ибится сердце перестало, вот заморочился то с оформлением...
al_ban; корум; Interrupted; +3 Ответить
18. grin_64 36 07.02.18 05:20 Сейчас в теме
Сервис больше недоступен?
19. rpgshnik 1775 07.02.18 05:38 Сейчас в теме
(18) странно буквально на днях работал все было отлично(( посмотрим сегодня.
Может поднимут...
20. Milanick 07.02.18 09:04 Сейчас в теме
Я у себя , по аналогии, ТНВЭД кода также реализовывал. Подгружались с сайта в регистр , а затем синхронизация с номенклатурным справочником :)
21. Milanick 07.02.18 09:05 Сейчас в теме
1С жулики, бесплатное превратили в платное :)
rpgshnik; +1 Ответить
22. OksanaSub 53 07.02.18 11:55 Сейчас в теме
23. rpgshnik 1775 07.02.18 11:56 Сейчас в теме
(22) сейчас не ясная ситуация, сервис не мой, сервис принадлежит самим ФНС... может работы ведутся.
Сам пока жду и наблюдаю за ситуацией. Так как уже много, что на этом завязано.

ссылка на сам сайт - http://npchk.nalog.ru/
28. rpgshnik 1775 08.02.18 09:43 Сейчас в теме
24. shard 251 07.02.18 13:18 Сейчас в теме
Восхищен оформлением :)
rpgshnik; +1 Ответить
25. rpgshnik 1775 07.02.18 13:36 Сейчас в теме
26. newbas 597 07.02.18 13:39 Сейчас в теме
оформление отличное.
Сайт почему-то не работает
rpgshnik; +1 Ответить
27. rpgshnik 1775 08.02.18 09:42 Сейчас в теме
29. grin_64 36 08.02.18 10:35 Сейчас в теме
30. rpgshnik 1775 08.02.18 10:46 Сейчас в теме
31. rpgshnik 1775 09.02.18 11:59 Сейчас в теме
Статью уже править не буду, но у себя добавил, советую и вам всем кто заинтересовался добавить ;)
Зачем это? Комментарии к публикации можете почитать и поймёте что почти три дня сервис лежал.
Сервис не стабильный - по этому лучше держать актуальные данные или что бы он отключался и пользователь понимал - что данной проверке нельзя доверять.

1. Константу - тип булево - включить/выключить функционал проверки контрагентов в ФНС
2. Константу - тип дата - содержит дату актуальной проверки

В формы которые я использую в справочнике Контрагентов я добавил в модуль формы переменную:

Перем ВыводитьСтатусФНС;


Затем я подвязал на открытие форм, процедуре ПриОткрытие

	ЭлементыФормы.СправочникСписок.Колонки.котСтатусФНС.Видимость = Константы.котПроверкаКонтрагентовВключен.Получить();
	ВыводитьСтатусФНС = НачалоДня(Константы.котПроверкаКонтрагентовФНСДатаПроверки.Получить()) = НачалоДня(ТекущаяДата());


Затем ещё скорректировал код при выводе строки:

	//Котов Д.В. +++ 31.01.2018
	//Так же можно выделять цветом всю строку целиком, тут ваш полёт фантазии не ограничен
	Если НЕ ОформлениеСтроки.ДанныеСтроки.ЭтоГруппа Тогда
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьТекст = ЛОЖЬ;
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьФлажок = ЛОЖЬ;
		оформлениеСтроки.Ячейки.котСтатусФНС.ОтображатьКартинку = ИСТИНА;
		Если ВыводитьСтатусФНС Тогда	//Котов Д.В. +++ 09.02.2018		
			Запрос = Новый Запрос;
			Запрос.Текст = "ВЫБРАТЬ
			|	котКонтрагентыСтатусФНС.Статус
			|ИЗ
			|	РегистрСведений.котКонтрагентыСтатусФНС КАК котКонтрагентыСтатусФНС
			|ГДЕ
			|	котКонтрагентыСтатусФНС.Контрагент = &Контрагент";	
			Запрос.УстановитьПараметр("Контрагент", ОформлениеСтроки.ДанныеСтроки.Ссылка);	
			Результат = Запрос.Выполнить();	
			Если Результат.Пустой() Тогда
				ОформлениеСтроки.Ячейки.котСтатусФНС.ИндексКартинки = 0;
			Иначе
				Выборка = Результат.Выбрать();
				Выборка.Следующий();		
				ОформлениеСтроки.Ячейки.котСтатусФНС.ИндексКартинки = котПроверкаКонтрагентов.НомерКартинкиСтатуса(Выборка.Статус); 
			КонецЕсли;
		Иначе
			ОформлениеСтроки.Ячейки.бгбСтатусФНС.ИндексКартинки = 0;	//Котов Д.В. +++ 09.02.2018
		КонецЕсли;
	КонецЕсли;
	//Котов Д.В. --- 31.01.2018
Показать


Результат данных действий простой:

1. Мы можем отключить алгоритм проверки статусов контрагентов в режиме предприятия онлайн!
2. Мы будем иметь только актуальные статусы, если каким-то образом проверка не прошла - тогда все иконки статусов будут "серыми".

Доработки общего модуля:

Ещё я добавил в общий модуль проверки - регламентной процедуры следующий код в самом начале:

Процедура котЕжедневнаяПроверкаКонтрагентов() Экспорт
	//Котов Д.В. +++ 09.02.2018 
	//Если механизм проверки не включен, тогда и проверять не нужно. Чтобы регламетной задание не отключать ;)
	Если НЕ Константы.котПроверкаКонтрагентовВключен.Получить() Тогда Возврат; КонецЕсли;
	//Решено актуализировать один раз на текущую дату, смотрите как вам удобнее.	
	Если НачалоДня(Константы.котПроверкаКонтрагентовФНСДатаПроверки.Получить()) = НачалоДня(ТекущаяДата()) Тогда Возврат; КонецЕсли;
	//Котов Д.В. --- 09.02.2018
	ПроверкаКонтрагентов();
КонецПроцедуры
Показать


А процедуре по проверке контрагентов "ПроверкаКонтрагентов()" добавил строчки по записи даты в константу:
Процедура ПроверкаКонтрагентов() Экспорт
	ДанныеПолучены = ЛОЖЬ;
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	СтатусыФНС.Контрагент
	|ИЗ
	|	РегистрСведений.котКонтрагентыСтатусФНС КАК СтатусыФНС
	|ГДЕ
	|	СтатусыФНС.Статус = ""1""";	
	Результат = Запрос.Выполнить();
	Если Результат.Пустой() Тогда
		УстановитьФильтр = ЛОЖЬ;
	Иначе
		УстановитьФильтр = ИСТИНА;
		КонтрагентыКоторыеНеДействуют = Результат.Выгрузить();
	КонецЕсли;
	Запрос = Новый Запрос;
	Запрос.Текст = "ВЫБРАТЬ
	|	Контрагенты.Ссылка КАК Контрагент,
	|	Контрагенты.ИНН,
	|	Контрагенты.КПП,
	|	ВЫРАЗИТЬ("""" КАК СТРОКА(100)) КАК Состояние,
	|	&ТекущайДата КАК Дата
	|ИЗ
	|	Справочник.Контрагенты КАК Контрагенты
	|ГДЕ
	|	Контрагенты.ИНН <> """"" +
	?(УстановитьФильтр,"И НЕ Контрагенты.Ссылка В(&ГруппаКонтрагентов)","");
	Запрос.УстановитьПараметр("ТекущайДата",ТекущаяДата());
	Запрос.УстановитьПараметр("ГруппаКонтрагентов",КонтрагентыКоторыеНеДействуют);
	ДанныеКонтрагента = Запрос.Выполнить().Выгрузить();		
	ПолучитьРезультатПроверкиВебСервисом(ДанныеКонтрагента,ДанныеПолучены);
	Если ДанныеПолучены Тогда
		Для Каждого Строка Из ДанныеКонтрагента Цикл		
			НаборЗаписей = РегистрыСведений.котКонтрагентыСтатусФНС.СоздатьНаборЗаписей();
			НаборЗаписей.Отбор.Контрагент.Установить(Строка.Контрагент); 
			НаборЗаписей.Прочитать();
			Если НаборЗаписей.Количество() > 0 Тогда
				ЗаписьТекущая = НаборЗаписей.Получить(0);
				Пропускать = ЗаписьТекущая.Статус = "1"; 
			Иначе
				Пропускать = ЛОЖЬ;
			КонецЕсли;
			Если НЕ Пропускать Тогда
				НаборЗаписей.Очистить();
				НаборЗаписей.Записать();
				НоваяЗапись = НаборЗаписей.Добавить(); 		   
				НоваяЗапись.Контрагент = Строка.Контрагент; 
				НоваяЗапись.Статус = Строка.Состояние; 
				НаборЗаписей.Записать(ИСТИНА); 		
			КонецЕслИ;					
		КонецЦикла;
		//Котов Д.В. +++ 09.02.2018 
		ДатаПроверки = Константы.схпПроверкаКонтрагентовФНСДатаПроверки;
		ДатаПроверки.Установить(ТекущаяДата());
		//Котов Д.В. --- 09.02.2018
	КонецЕсли;
КонецПроцедуры
Показать
32. LomayaZakat 27.03.18 15:29 Сейчас в теме
Не работает, при ответе выдает ошибку
33. LomayaZakat 28.03.18 08:10 Сейчас в теме
Проблема решилась на стороне фаервола
rpgshnik; +1 Ответить
34. rpgshnik 1775 02.04.18 05:52 Сейчас в теме
(33) отлично, в командировке был)) вообще сервис носит тестовый характер, было дело лежал почти неделю
38. Yashazz 2906 30.05.18 12:53 Сейчас в теме
Увидел фразу
WSПрокси = ОбщегоНазначения.WSПрокси(

и сразу захотелось резко минуснуть за столь откровенную хрень.
Оформление оформлением, но так не делают. Что это за отсылки к неведомым общим модулям?
39. AASycheva 05.06.18 12:14 Сейчас в теме
Здравствуйте. Вы сняли cf с возможности скачивания? Почему-то не удается скачать его. В техподдержке сказали, что вы закрыли возможность скачивания. Но странно, ведь здесь все еще есть возможность отправить себе на почту. Да и поддержку вы ведете
40. rpgshnik 1775 06.06.18 04:14 Сейчас в теме
(39) Здравствуйте. Ни чего не закрывал и не чего не снимал, очень странно.
Судя по логу то после вас и до вас успешно скачали пользователи (скриншот ниже).

Вы первый раз скачиваете с инфостарта? Вам на почту должна придти ссылка, а через неё уже скачать.
Прямого скачивания (не через почту) здесь просто нет на инфостарте.
Прикрепленные файлы:
41. AASycheva 07.06.18 20:39 Сейчас в теме
(40) нет, не в первый. В том-то и дело, что приходит ссылка, по которой невозможно скачать. В техподдержке, видимо, решили не разбираться и свалили всё на автора публикации. Спасибо, буду разбираться дальше
rpgshnik; +1 Ответить
42. grin_64 36 13.11.18 16:19 Сейчас в теме
Добрый день!
Почему-то не работает сервис. Только желтые и красные иконки.
На сайте http://npchk.nalog.ru все хорошо
43. rpgshnik 1775 14.11.18 04:23 Сейчас в теме
(42) Добрый день!
Можете попробовать очистить регистр сведений со статусами и прогрузить их все по новой. Если регистр заполниться - значит функционал работает.
44. miwka77 28.12.18 15:45 Сейчас в теме
Вдвоем с программистом подняли у себя данный сервис. Все работало, но с октября 2018 перестало. У нас клиент-сервер. Версия сервера и клиента 8.2 (130). Я - Админ. Программист проверила процедуру несколько раз - она типовая, как у топикстартера.
Опытным путем нашли, что запрос вроде отсылается, а вот ответ то ли не приходит, то ли приходит неверный. В одной из похожих тем видел совет про кодировку файла-ответа, но как проверить не знаю. Я провел несколько экспериментов. На том же сервере, но на другом порту работает Трешечный сервер. Прикрутил к нему базу и загрузил в нее DT-шник базы 8.2 (где не работает запрос). Оно там работает!
Сформулировал несколько вопросов, на которые не могу найти ответа:
1. если бы было дело в файерволе, то не работало бы и в трешке. Сервер то один. Да?
2. пробовал стандартные и классические "почистить кэши", "проверить настройки Интернет на сервере" - все чистил и проверял. Инет есть, сервак 8.2 вообще переинсталлил с удалением записей из реестра и каталогов. Инет работает без прокси, если что. Все ли я попробовал?
3. При открытии URL-запроса инфы из ФНС, у меня немного разный ответ, если открывать на клиенте и сервере. Могу приложить, но суть такова: запрос на серваке идет на 443 порт, а если обращаюсь со своей машины, то там 80 порт. Причем автоматом. Не понимаю в чем разница. Вероятно на стороне сервиса. По-моему, это все хня, но на всякий случай пишу.
4. Вообще, все сотрудники работают на терминальном серваке. Он в одной сетке с сервером 1С. Это разные хосты. Я подключился к сетке Сервера 1С через VPN и подключился к базе с другого клиента. Тоже самое - не работает. Но создаю файловую копию базы на этом же клиенте, и вуаля - работает запрос в ФНС. Это все, в течении 30 минут, чтобы не было соблазна сказать, что мол сервис был недоступен.

Дословно, ошибку из журнала после отработки процедуры, можно посмотреть под катом
{ОбщийМодуль.ОбщегоНазначения.Модуль(5634)}: Ошибка при вызове конструктора (WSОпределения)
Возврат Новый(Тип("WSОпределения";), Параметры);
по причине:
Ошибка разбора XML: - [1,1]
Фатальная ошибка: 
Extra content at the end of the document
SystemId: https://npchk.nalog.ru:443/FNSNDSCAWS_2?xsd=1
45. AlexandrSmith 48 25.09.19 13:44 Сейчас в теме
Спасибо огромное автору статьи, за отличное освещение темы. Успешно создал на основании его рекомендации проверку в ФНС. Искренне благодарен. Прошу обратить внимание на особенности настройки портов антивирусов и файрволов. Очень обидно будет, если не заработает, так было у меня, но я успешно справился с этим. Желаю всем удачи.
Alex1053669; rpgshnik; +2 Ответить
46. rpgshnik 1775 25.09.19 14:03 Сейчас в теме
47. mikl79 107 26.09.19 14:51 Сейчас в теме
Спасибо за разработку, подскажите нет ли такой же для Управляемых форм?
49. rpgshnik 1775 27.09.19 03:37 Сейчас в теме
(47) Сама публикация это подробное описание как это сделать самостоятельно, да в качестве примера указана Комплексная автоматизация 1.1 и обычные формы, но в конце публикации привожу пример как данный модуль использовать и для управляемого интерфейса. Посмотрите "Посткриптум".
48. mikl79 107 26.09.19 15:20 Сейчас в теме
Я поторопился и ошибся, есть ли Бесплатное Заполнение (создание) контрагента по ИНН или Наименованию?
50. Elf77 3 15.11.19 10:00 Сейчас в теме
51. Elf77 3 15.11.19 12:45 Сейчас в теме
При загрузке cf-ника в пустую базу поругался на ошибочное значение во "вводе по строке" для справочника "Контрагенты".
Хотя это конечно поправимо..
Оставьте свое сообщение

См. также

Описание формата внутреннего представления данных 1С в контексте обмена данными 153

Статья Программист Внешняя обработка (ert,epf) v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных Разработка

Фирма 1С не рекомендует использовать внутреннее представление данных для любых целей, которые отличны от обмена с 1С:Предприятием 7.7. Но сама возможность заглянуть на "внутреннюю кухню" платформы с помощью функций ЗначениеВСтрокуВнутр(), ЗначениеВФайл(), ЗначениеИзСтрокиВнутр() и ЗначениеИзФайла(), дала возможность сообществу программистов 1С разработать новые приемы разработки и анализа. Так, именно на использовании внутреннего представления был построен алгоритм "быстрого массива", который позволяет практически мгновенно создать массив в памяти на основании строки с разделителями. С помощью разбора внутреннего представления можно "на лету" программным кодом выполнить анализ обычной формы и даже сделать редактор графической схемы. Во внутреннем формате сохраняют свои данные между сеансами различные популярные внешние обработки. А еще это возможность сделать быстрый обмен с внешними системами.

1 стартмани

06.09.2019    6862    6    Dementor    27       

Программы для исполнения 488-ФЗ: Маркировка товаров Промо

1 января 2019 года вступил в силу ФЗ от 25.12.2018 № 488-ФЗ о единой информационной системе маркировки товаров с использованием контрольных (идентификационных) знаков, который позволяет проследить движение товара от производителя до конечного потребителя. Инфостарт предлагает подборку программ, связанных с применением 488-ФЗ и маркировкой товаров.

Вам нравятся запросы в 1С? 14

Инструменты и обработки Программист Конфигурация (md, cf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования Разработка

Речь не только о том, что простейший запрос с "легальным" оформлением растянется на пол-экрана, речь еще обо всем, что нужно написать "в нагрузку" к тексту запроса. Все эти "Новый Запрос", "УстановитьПараметр" и последующие пляски с обработкой результата... Пора с этим заканчивать!

1 стартмани

03.07.2019    11380    1    m-rv    79       

1С:Ассемблер. Немного летнего веселья! 313

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования Разработка

Все вы, наверное, слышали, что 1С-ники жалуются на свою систему, считая язык 1С недостаточно низкоуровневым, скучным и т.п. Все они с тоской поглядывают в сторону "настоящих" языков программирования. Так вот, господа, они неправы. В системе 1С есть места, где можно размять программерский мозг и получить удовольствие от низкоуровневой техники. Предлагаю вам погрузиться в недра виртуальной машины 1С и понять, как она работает. Там есть свой "ассемблер" и мы попробуем его в действии!

1 стартмани

21.06.2019    15997    49    Evil Beaver    116       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Простые примеры сложных отчетов на СКД 270

Статья Программист Архив с данными v8 v8::СКД 1cv8.cf Абонемент ($m) Практика программирования

Подписи в отчете. Особенности соединения наборов: как соединить несоединяемое. Остатки на дату и обороты по месяцам в одном отчете. Курс валюты на каждую дату без группировок и соединений в запросе. Отчет с произвольными колонками и с произвольной последовательностью. "Неадекватный отчет".

1 стартмани

12.06.2019    15750    11    Hatson    22       

Безопасная работа с транзакциями во встроенном языке 190

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Разбираемся с опасностями использования транзакций во встроенном языке 1С. Познаем ошибку "В данной транзакции уже происходили ошибки". Учимся защищаться от них.

1 стартмани

25.03.2019    17661    8    tormozit    44       

С 2020 года сервис «Продление поддержки конфигурации 1С:УПП» подорожает вдвое Промо

Успейте продлить поддержку УПП до повышения цен! Фирма «1С» предупредила об изменении цен на сервис «Продление поддержки конфигурации "1С:Управление производственным предприятием"». С 1 января 2020 года сервис подорожает в два раза.

Баг или фича? Неожиданное поведение платформы 172

Статья Системный администратор Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Тестирование и исправление Разработка

Рассмотрим несколько случаев неожиданного поведения платформы 1С, а также что с этим можно cделать.

18.02.2019    13958    32    YPermitin    88       

Коннектор: удобный HTTP-клиент для 1С:Предприятие 8 562

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования Внешние источники данных WEB Универсальные функции Инструментарий разработчика Универсальные обработки

Коннектор - библиотека для работы с HTTP запросами. Библиотека берет на себя всю рутину работы с HTTP запросами. Буквально в одну строку можно получать данные, отправлять, не заботясь о необходимости конструирования URL, кодирования данных и т.п.

1 стартмани

31.01.2019    31243    281    bonv    117       

Перенос документов и справочников ERP 2 / КА 2 / УТ 11 => БП 3.0 Промо

Перенос позволяет настроить собственный обмен данными между указанными программами, альтернативный предлагаемому фирмой 1С. Предоставляем техподдержку по всем вопросам данного обмена. Можем подключиться к вам удаленно для разбора ситуаций. Оперативно обновляем при выходе новых релизов 1С. Бесплатные обновления в течение полугода.

19700 руб.

HTML в новой версии 8.3.14 на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX 172

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Универсальные обработки Практика программирования Разработка

Тестируем возможности HTML в новой версии 8.3.14 платформы на примере 3-х JavaScript библиотек: AmCharts, HighCharts, DHTMLX.

1 стартмани

29.01.2019    15944    66    Synoecium    37       

Отладка сложных отчетов на СКД 140

Отчеты и формы Программист Расширение (cfe) v8 v8::СКД 1cv8.cf Россия Абонемент ($m) Практика программирования

Расширение для отладки сложных отчетов на СКД (в т.ч. для собираемых программно "на лету") и быстрого перехода к отладке таких отчетов в консоли запросов и отчетов на СКД.

1 стартмани

28.12.2018    15756    61    maxx    56       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Реализация простого http-сервиса "Просмотр карточки номенклатуры(товара) в браузере" 144

Статья Программист Конфигурация (md, cf) v8 1cv8.cf Абонемент ($m) Практика программирования

Практический пример реализации простого http-сервиса средствами 1С Предприятие 8.3. Обеспечивает просмотр списка товаров и просмотр данных товара в браузере.

1 стартмани

07.12.2018    14856    10    dmitry1975    31       

Использование подсистемы БСП "Заполнение объектов" 135

Статья Программист Расширение (cfe) v8 v8::УФ 1cv8.cf Россия Абонемент ($m) Практика программирования Универсальные функции БСП (Библиотека стандартных подсистем)

Применение механизмов БСП для добавления новых команд заполнения к формам различных объектов. Использование расширений конфигурации для доработки. Шаблоны для реализации собственных команд заполнения.

1 стартмани

23.11.2018    15161    8    ids79    22       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Работа с публикациями "Инфостарт" 14

Инструменты и обработки Программист Архив с данными v8 УУ Абонемент ($m) Практика программирования О сообществе WEB

Работа с рублевыми публикациями на сайте "Инфостарт": ведение клиентов, заказов, обновление файлов публикации, рассылка обновлений.

1 стартмани

13.09.2018    10751    10    RocKeR_13    16       

HTTP Сервисы: Путь к своему сервису. Часть 3 138

Инструменты и обработки Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Инструментарий разработчика Практика программирования

Продолжение статьи «HTTP Сервисы: Путь к своему сервису. Часть 2». В предыдущих частях мы использовали только Get, в этой части поговорим о других методах и длительных операциях.

1 стартмани

27.08.2018    18485    32    dsdred    13       

Программы для исполнения 54-ФЗ Промо

С 01.02.2017 контрольно-кассовая техника должна отправлять электронные версии чеков оператору фискальных данных - правила установлены в 54-ФЗ ст.2 п.2. Инфостарт предлагает подборку программ, связанных с применением 54-ФЗ, ККТ и электронных чеков.

Позиционирование в помещении с помощью нейросети по сигналу Wi-Fi. Интерактивная карта склада в 1С с показом позиции 65

Инструменты и обработки Программист Бизнес-аналитик Приложение (apk) v8 Windows Абонемент ($m) Инструментарий разработчика Практика программирования

Данная публикация содержит в себе редактор и интерактивную карту склада или иного помещения, на которой в реальном времени отображается позиция устройства, координаты которого вычисляются по уровням сигнала нескольких роутеров Wi-Fi. В статье и приложенным к ней разработкам предлагаются инструменты и методика для реализации вычисления точной геопозиции внутри помещений с помощью нейронной сети. Конфигурация написана на релизе 1С:Предприятие 8.3.12.1412, клиентское приложение имеет минимальный уровень совместимости SDK -16.

5 стартмани

09.08.2018    17375    23    informa1555    26       

Работа с данными выбора 41

Инструменты и обработки Программист Архив с данными v8 Россия Абонемент ($m) Практика программирования Работа с интерфейсом

В управляемом интерфейсе заложена мощная возможность описывать связи реквизитов формы через параметры. Установка параметров связей позволяет ограничить выбор данных так, чтобы целостность данных была обеспечена на этапе ввода. Однако без дополнительного программирования задать можно только самые простые связи. Такие условия связи, как зависимость от реквизита через точку или зависимость через дополнительное отношение, заданное в регистре сведений - уже задать без программирования не получится.

1 стартмани

17.07.2018    24357    14    kalyaka    15       

Перенос данных КА 1.1 => ERP 2 (ЕРП) (обработка переноса документов, остатков и справочной информации из "1С:Комплексная автоматизация, ред. 1.1" в "1С:ERP Управление предприятием, ред 2"). Обновлен до КА 1.1.115.х и ERP 2.4.10.х Промо

Обработка позволяет переносить из КА 1.1 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления в случае выхода новых релизов конфигураций 1С.

29700 руб.

HTTP Сервисы: Путь к своему сервису. Часть 1 287

Статья Системный администратор Программист Расширение (cfe) v8 1cv8.cf Абонемент ($m) Практика программирования WEB

Уже много было написано про http-сервисы, но то и дело всплывают «Новые» статьи по обмену между базами V8 по COM, что «Немножко» удивляет. Решил внести свои 5 копеек, поработаем с http-сервисом.

1 стартмани

15.07.2018    43153    17    dsdred    22       

ВСТАВИТЬ В Справочник.Номенклатура (Код, Наименование) ЗНАЧЕНИЯ ("001", "Новый товар") 105

Инструменты и обработки Программист Внешняя обработка (ert,epf) v8 v8::Запросы 1cv8.cf Абонемент ($m) Практика программирования

Вас не обманывают ваши глаза, это запрос на изменение данных! И это работает без прямого доступа к БД, регистрации и смс.

1 стартмани

01.06.2018    21002    86    m-rv    57       

Перенос данных КА 1.1 / УПП 1.3 => БП 3.0 (перенос остатков, документов и справочников из "1С:Комплексная автоматизация 1.1" / УПП 1.3 в "1С:Бухгалтерия 3.0"). Обновлен до версий КА 1.1.115.х, УПП 1.3.127.х! Промо

Разработка позволяет перенести остатки по всем счетам бух.учета в программу "1С:Бухгалтерия предприятия 8", ред. 3.0 на выбранную дату начала ведения учета. Также переносятся документы за период и вся необходимая справочная информация. Правила оперативно обновляю при выходе новых релизов. Рассылка обновлений правил бесплатно в течение 12 месяцев. Есть видеодемонстрация проведения переноса данных. Конфигурации при использовании обмена остаются полностью типовыми. Перенос данных возможен в Бухгалтерию 3.0 версии ПРОФ, КОРП или базовую.

24700 руб.

БСП: Дополнительная обработка (Регламенты), примеры от простого к сложному 242

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования БСП (Библиотека стандартных подсистем)

Очень много попадается странных решений, которые можно решить через БСП:Дополнительные отчеты и обработки. Я бы вообще БСП из-за этой подсистемы переименовал в «Большое Спасибо Программистам». Поработаем с подсистемой в части написания регламентных заданий.

1 стартмани

10.05.2018    29552    28    dsdred    34       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.127.х, КА 2.4.10.х и ERP 2.4.10.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Как выполнить отчет на СКД через COM и получить данные отчета? 86

Статья Программист Архив с данными v8 УПП1 Россия Windows Абонемент ($m) Практика программирования

Для чего это нужно. Например, нужно в одной базе получить какой-либо показатель из другой базы. Этот показатель вычисляется в каком-либо сложном отчете, который написан на СКД. Можно, конечно, "скопипастить" текст запроса из другой базы, немного подправить его и выполнять в том же COM подключении. Но с этим теряется гибкость: если отчет изменился, то нужно помнить о том, что где-то есть его "немного модифицированная" копия. В статье будет рассмотрен пример получения данных из базы ЗУП.

2 стартмани

08.05.2018    19116    10    wowik    3       

Работа со схемой запроса 176

Статья Программист Конфигурация (md, cf) v8 v8::Запросы Абонемент ($m) Инструментарий разработчика Практика программирования

Стандартом взаимодействия с реляционной базой данных стал язык SQL. Приемником SQL в 1С является язык запросов. Язык запросов, также как и SQL, является структурированным. Составляющие структуры запроса отвечают на разные вопросы о том, какие данные требуется получить и какие манипуляции с множествами данных необходимо произвести при получении. В простых случаях текст запроса можно написать вручную, однако в сложных случаях, а также при программном формировании, - лучше воспользоваться объектной моделью запроса и использовать объект "Схема запроса". В статье дается описание объектной модели и особенностей работы с ней, а также приводится решение, упрощающее взаимодействие с объектом "Схема запроса".

1 стартмани

24.04.2018    30370    75    kalyaka    34       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.10.х и УТ 11.4.10.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Асинхронная запись и чтение файла без использования модальных методов и временных файлов 134

Статья Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Практика программирования

В статье рассмотрено решение задачи формирования и записи файла на основе данных информационной базы. Формирование происходит на стороне сервера с помощью механизма потоков. Используются асинхронные методы передачи файлов между клиентом и сервером. Также рассмотрено решение обратной задачи - чтение файла и запись его данных в информационную базу. Статья ориентирована прежде всего на новичков, также приведенный код может использоваться в качестве шаблона.

1 стартмани

10.04.2018    20105    18    Alxby    23       

Заполняем по шаблону (по умолчанию) 69

Инструменты и обработки Программист Архив с данными v8 v8::УФ 1cv8.cf Абонемент ($m) Практика программирования

Простой в подключении, универсальный и достаточно удобный механизм заполнения реквизитов произвольных документов/справочников значениями по умолчанию. Реализован в расширении, но может быть и непосредственно включен практически в любую конфигурацию на управляемых формах простым копированием одной формы и двух команд. Весь код в статье.

1 стартмани

08.02.2018    18870    20    mvxyz    17       

Очный семинар по регулярному менеджменту Александра Фридмана "Вы или Хаос", 12 декабря 2019 г. , Санкт-Петербург Промо

Семинар по регулярному менеджменту от Александра Фридмана для собственников, первых лиц и топов. Технология управленческого планирования, комплексного управления временем и другими ресурсами, выполнением поручений, делами, информацией, контактами (встречи-звонки-почта).

от 11000 до 29000 рублей

Программное создание динамического списка на управляемой форме. (Динамическое создание динамического списка). Готовая процедура + обработка - демонстрационный пример 277

Статья Программист Внешняя обработка (ert,epf) v8::УФ 1cv8.cf Абонемент ($m) Практика программирования Универсальные функции

Если у вас возникает необходимость на форму влиять динамически и создавать элементы управляемой формы программно, а особенно хотите вывести программно (динамически) динамический список, вам будет интересна эта процедура. Процедура включает также возможность формирования своей командной панели (а-ля снятие галочки "Автозаполнение" у стандартной командной панели списка).

1 стартмани

19.01.2018    41691    62    rpgshnik    26       

Расширение возможностей печати: Вывод произвольного нижнего и верхнего колонтитула 8

Отчеты и формы Программист Внешняя обработка (ert,epf) v8 1cv8.cf Абонемент ($m) Печатные формы документов Практика программирования Универсальные функции

Расширяем функционал вывода нижнего / верхнего колонтитула. Стандартно 1С имеет достаточно ограничений по выводу и наполнению колонтитулов содержимым, взять хотя бы такие, как вывод только текста и отсутствие ограничения на номер конечной страницы. А при разработке кода сталкиваешься с тем, что свой блок с нижним колонтитулом нужно прижимать к низу страницы. Казалось бы быстро решаемый вопрос, но и в нем есть нюансы. Сейчас я расскажу о том, как решалась эта задача. UPD 15.02.2018. Добавлен вывод верхнего колонтитула; Вывод колонтитулов на первой и последней странице управляется параметрами; Научился считать страницы: Добавлено заполнение переменных аналогичных стандартным из колонтитулов; Задаются форматы даты и времени. Ограничения прежние: 1. Повторно сформировать табличный документ после смены параметров страницы интерактивно.; 2. Передавать данные для более плотной печати как можно более мелко нарезанными кусками.

1 стартмани

29.12.2017    24865    21    agent00mouse    0