Сканирование QR кодов через WEB-камеру

Публикация № 595637

Разработка - Разработка внешних компонент

Программа вэб камера qr код

Программа для считывания QR кодов через вэб-камеру.

Программа не требует установки. Единственное условие - наличие установленного framework 4.0 и старше. Состоит из двух библиотек и выполняемого файла.

1. Запускаем программу. 

2. Подносим QR код.

3. Программа считывает и закрывается. 

В каталоге программы создается файл Output.txt с одной строкой формата: True|563067. Первый параметр  "True" или "False" - статус сканирования. Второй - штрих код или описание ошибки.

Пример процедуры чтения QR кода. Используется для чтения кодов UDS GAME со смартфонов покупателей. 

Процедура ОсновныеДействияФормыСканироватьКодUDS(Кнопка)
	
	КаталогИБ = КаталогИБ();
	Если КаталогИБ = КаталогВременныхФайлов() Тогда
		КаталогИБ = КаталогДокументов();
	КонецЕсли; 
	КаталогИБ = КаталогИБ+"QRreader\";
	
	МассивФайловРезультата = НайтиФайлы(КаталогИБ,"output.txt",Истина);
	Если НЕ МассивФайловРезультата.Количество() = 0 Тогда
		ФайлРезультата = МассивФайловРезультата[0];
		УдалитьФайлы(КаталогИБ+"output.txt");
	КонецеслИ;
	
	МассивФайлов = НайтиФайлы(КаталогИБ,"QRDecoder.exe",Истина);
	Если МассивФайлов.Количество() = 0 Тогда
		Предупреждение("Не установлена программа для чтения QR-кодов!", 60);
	Иначе
		ФайлQRreader = МассивФайлов[0].ПолноеИмя;
		ЗапуститьПриложение(ФайлQRreader, КаталогИБ, Истина,);
		
		МассивФайловРезультата = НайтиФайлы(КаталогИБ,"output.txt",Истина);
		Если НЕ МассивФайловРезультата.Количество() = 0 Тогда
			ФайлРезультата = МассивФайловРезультата[0];
	        ТД = Новый ТекстовыйДокумент;
			ТД.Прочитать(КаталогИБ+"output.txt");
			СтрокаОтвета = ТД.ПолучитьСтроку(1);
			Если СтрокаОтвета <> "" Тогда
				ПозицияРазделителя = Найти(СтрокаОтвета, "|");
				Если ПозицияРазделителя <> 0 Тогда
					ОтветПрограммы = Лев(СтрокаОтвета, ПозицияРазделителя-1); 
			        Если ОтветПрограммы = "True" Тогда
						КодСкидкиUDS = Сред(СтрокаОтвета, ПозицияРазделителя+1, СтрДлина(СтрокаОтвета)-ПозицияРазделителя);
						Если КодСкидкиUDS <> "" Тогда
							
							Отказ = Ложь;
							ИмяКлиента = "";
							СуммаСкидки = 0;
							ОтветСкидки = UDSGame.GET_Customer(КодСкидкиUDS); 
							ЧтениеJSON = Новый ЧтениеJSON;
							ЧтениеJSON.УстановитьСтроку(ОтветСкидки);
							
							СтруктураОтвета = ПрочитатьJSON(ЧтениеJSON, ,"dateCreated");
							
							Если СтруктураОтвета.Свойство("scores") Тогда 
								СуммаСкидкиUDS = СтруктураОтвета.scores; 
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("name") Тогда
								nameUDS = СтруктураОтвета.name;
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("surname") Тогда
								surnameUDS = СтруктураОтвета.surname;
							КонецЕсли;
							
							Если СтруктураОтвета.Свойство("errorCode") Тогда
								Предупреждение("Получена ошибка: " + СтруктураОтвета.errorCode, 60);
								Отказ = Истина;
							КонецЕсли;
							
							Если Не Отказ Тогда
								ЭтаФорма.Закрыть();
							КонецЕсли; 
							
						Иначе
							Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);	
						КонецЕсли; 
					Иначе
						Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);
					КонецЕсли; 
				Иначе
					Предупреждение("Не удалось считать код. Попробуйте считать снова.",60);	
				КонецЕсли; 
			КонецЕсли; 
		КонецЕсли; 
	КонецЕсли;
	
КонецПроцедуры

Скачать файлы

Наименование Файл Версия Размер
QRreader.zip
.zip 161,39Kb
09.03.17
19
.zip 161,39Kb 19 Скачать

Специальные предложения

Комментарии
Избранное Подписка Сортировка: Древо
2. Sergik_D 17 21.11.17 09:47 Сейчас в теме
(0) Здравствуйте. Не понял что Вам скинуть? Я код описал работы с программой. У меня не стандартная конфигурация, она Вам не подойдет. Если нужно интегрировать, напишите, обсудим.
3. Vladimir45 66 28.02.18 13:53 Сейчас в теме
А как указать что надо использовать не фронтальную, а заднюю камеру на планшете с виндой?
4. Crazy_Max 63 15.06.18 07:33 Сейчас в теме
А может быть исходный код библиотеки выложите, если вы его не распространяете в коммерческих целях? Хотелось бы сэкономить время и дополнить тот функционал, который хотелось бы лично мне...
Оставьте свое сообщение

См. также

Маленькая и скромная мобильная внешняя компонента

Вопрос Программист Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Изваять простенькую мобильную компоненту на 1С для android не так-то просто. Посему назло отдельным супостатам, не желающим делится исходниками, представляю весь свой скромный труд на публичный суд.

1 стартмани

21.10.2019    4590    1    ripreal1    16       

Онлайн-курс «Практические аспекты внедрения регламентированного учета и расчета себестоимости в 1С:ERP на крупных промышленных предприятиях» с 17 февраля по 13 марта 2020 года. Промо

Курс рассчитан для подготовки экспертов по регламентированному учету и учету затрат для внедрения на крупных промышленных предприятиях с «исторически сложившимся» учетом

9000 рублей

Native внешняя компонента для оповещения по UDP или TCP

Инструменты и обработки Программист Архив с данными v8 Windows Абонемент ($m) Разработка внешних компонент

Native внешняя компонента для оповещения по UDP или TCP, которая реализует возможность в 1С передавать сообщения с сервера на клиента. Исходный код компоненты также представлен.

1 стартмани

06.10.2019    4147    7    vdv2701    10       

Рекомендательный сервис на основе коллаборативной фильтрации на 1С. Расширение формы подбора для УТ 11.4

Инструменты и обработки Программист Расширение (cfe) v8 ERP2 УТ11 КА2 Розничная и сетевая торговля (FMCG) Оптовая торговля, дистрибуция, логистика Россия УУ Абонемент ($m) Оптовая торговля Розничная торговля Практика программирования Математика и алгоритмы

В данной разработке реализован механизм рекомендаций товаров по принципу схожести товаров в корзине на основе алгоритма Item-to-Item от Amazon. Разобран алгоритм с демо базой и сделано расширение для УТ11.4 которое добавляет в форму подбора таблицу рекомендаций. Протестировано на 8.3.13.1865 на Управление торговлей, редакция 11 (11.4.8.63)

3 стартмани

25.09.2019    4055    8    informa1555    24       

Перенос данных УПП 1.3 => ERP 2 (ЕРП) / УТ 11 / КА 2.х (обработка переноса документов, остатков и справочников из "1С:Управление производственным предприятием, ред. 1.3" в ERP / УТ 11 / КА 2). Обновлен до УПП 1.3.130.х, КА 2.4.11.х и ERP 2.4.11.х! Промо

Обработка позволяет переносить из УПП 1.3 в ERP 2 документы за выбранный период и остатки. Типовая обработка от фирмы 1С документы не переносит. Также исправлены ошибки типовой обработки. При выходе новых релизов обновление высылается бесплатно в течение года. Разработка будет полезна фирмам-франчайзи, которые периодически выполняют такой перенос данных для заказчиков. Вы можете один раз приобрести обработку переноса, и потом бесплатно получать обновления при выходе новых релизов конфигураций 1С.

29700 руб.

Выгрузка номенклатуры в социальную сеть Вконтакте

Инструменты и обработки no Внешняя обработка (ert,epf) v8 1cv8.cf Оптовая торговля Розничная торговля Абонемент ($m) WEB

Обработка для быстрой и легкой выгрузки товаров Вконтакт. Так просто еще не было)))

2 стартмани

14.08.2019    5104    17    kalyuzhny    25       

Создание платежного поручения по QR-коду

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8::БУ БП2.0 БУ Банковские операции Абонемент ($m) Обработка документов

Автоматическое создания платежного поручения по QR-коду (ГОСТ Р 56042-2014 Стандарты финансовых операций) для типовой Бухгалтерии 2.0. Тестировалось на платформе 8.3.13.1644, конфигурации 1С: Бухгалтерия 2.0.66.81.

1 стартмани

12.08.2019    1943    rav_    0       

Базовый курс для начинающих 1С-программистов. Пятый поток. Онлайн-курс с 12 февраля по 15 апреля 2020 г. Промо

Данный онлайн-курс является начальной ступенью по изучению базовых принципов программирования в системе “1С:Предприятие” и предназначен для обучения 1С-программированию “с нуля”.

4500/9500 рублей

Онлайн-курс "Подготовка к экзамену 1С:Эксперт и 1С:Профессионал по технологическим вопросам" с 7 по 24 апреля 2020 г. Промо

На курсе вы получите практические навыки решения задач производительности 1С, в том числе характерных для высоконагруженных информационных систем (более 1000 пользователей). Подготовка к экзамену – только одна из составляющих курса. 70% слушателей приходят за знаниями, которые позволят расти и зарабатывать, делать сложные задачи на крупных проектах.

16450 рублей

Конструктор мобильного клиента Simple WMS Client: способ создать полноценный ТСД без мобильной разработки. Теперь новая версия - Simple UI (обновлено 14.11.2019)

Инструменты и обработки Программист Архив с данными v8 v8::Mobile БУ УУ Android Оптовая торговля Производство готовой продукции (работ, услуг) Розничная торговля Учет ОС и НМА Учет ТМЦ Абонемент ($m) Инструментарий разработчика Сканер штрих-кода Терминал сбора данных Мобильная разработка

Simple WMS Client – это визуальный конструктор мобильного клиента для терминала сбора данных(ТСД) или обычного телефона на Android. Приложение работает в онлайн режиме через интернет или WI-FI, постоянно общаясь с базой посредством http-запросов (вариант для 1С-клиента общается с 1С напрямую как обычный клиент). Можно создавать любые конфигурации мобильного клиента с помощью конструктора и обработчиков на языке 1С (НЕ мобильная платформа). Вся логика приложения и интеграции содержится в обработчиках на стороне 1С. Это очень простой способ создать и развернуть клиентскую часть для WMS системы или для любой другой конфигурации 1С (УТ, УПП, ERP, самописной) с минимумом программирования. Например, можно добавить в учетную систему адресное хранение, учет оборудования и любые другие задачи. Приложение умеет работать не только со штрих-кодами, но и с распознаванием голоса от Google. Это бесплатная и открытая система, не требующая обучения, с возможностью быстро получить результат.

5 стартмани

09.01.2019    28185    231    informa1555    198       

Готовые переносы данных из различных конфигураций 1C Промо

Рекомендуем готовые решения для переноса данных из различных конфигураций 1C. C техподдержкой от разработчиков и гарантией от Инфостарт.

Внешняя компонента для выполнения регулярных выражений

Инструменты и обработки Программист Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Внешняя Native API компонента для выполнения регулярных выражений на платформе 1С:Предприятие 8. Написана на C++. Используется движок boost::regex (v 1.69, v 1.68 - для Android). Версия синтаксиса Perl Compatible Regular Expressions.

1 стартмани

12.11.2018    7778    24    KAV2    57       

Новый раздел на Инфостарте - Electronic Software Distribution Промо

Инфостарт напоминает: на нашем сайте можно купить не только ПО, связанное с 1С. В нашем арсенале – ESD-лицензии на ПО от ведущих вендоров: Microsoft, Kaspersky, ESET, Dr.Web, Аскон и другие.

  • Низкие цены, без скрытых платежей и наценок
  • Оперативная отгрузка
  • Возможность оплаты с личного счета (кешбек, обмен стартмани на рубли и т.п.)
  • Покупки идут в накопления для получения скидочных карт лояльности Silver (5%) и Gold (10%)

Загрузка чека онлайн-касс (загрузка товаров из чека)

Инструменты и обработки Системный администратор Программист Бухгалтер Внешняя обработка (ert,epf) v8 1cv8.cf Кассовые операции Розничная торговля Абонемент ($m) Внешние источники данных WEB

Обработка-пример, позволяет любому и из любой конфигурации загрузить информацию о товарах из чека(и не только) с сервера ФНС proverkacheka.nalog.ru

2 стартмани

08.10.2018    10577    26    echo77    33       

Кое-что простое о сложных штрих-кодах

Инструменты и обработки Программист Конфигурация (md, cf) v8 1cv8.cf УУ Розничная торговля Абонемент ($m) Сканер штрих-кода Бухгалтерский учет

На просторах и-нета часто встречаю публикации, в которых авторы с энтузиазмом рассказывают о том, как в штрих-код внести информацию о нескольких сущностях: например, как сделать, чтобы при сканировании одного штрих-кода на ярлыке товара, 1С определяла что это за товар, его качество и приходную накладную по которой этот товар поступил. Увы, но делается это "в лоб". Я предлагаю более разумный способ. Он очевиден - так что не претендую на лавры первооткрывателя.

1 стартмани

28.09.2018    9236    6    torch    15       

Подборка решений для взаимодействия со ФГИС «Меркурий» Промо

С 1 июля 2019 года все компании, участвующие в обороте товаров животного происхождения, должны перейти на электронную ветеринарную сертификацию (ЭВС) через ФГИС «Меркурий». Инфостарт предлагает подборку программ, связанных с этим изменением.

Расширение "Интерфейс Плюс"

Отчеты и формы Бухгалтер Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия УУ Розничная торговля Абонемент ($m) Рабочее место

Расширение для 1С:Розница 2.2 и 1С:Управление Торговлей 11, которое позволит повысить удобство работы!

3 стартмани

22.09.2018    13145    107    RocKeR_13    86       

TextRadar - нечеткий поиск в тексте

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 1cv8.cf Абонемент ($m) Разработка внешних компонент Поиск данных

В отличие от нечеткого сравнения строк, когда обе сравниваемых строки равнозначны, в задаче нечеткого поиска выделяются строка поиска и строка данных, а вычислить необходимо не степень похожести двух строк, а степень присутствия строки поиска в строке данных. Нормированный коэффициент, находящийся между 0 и 1 позволяет отсечь заведомо низкие результаты, организовать поиск по синонимам и т.д. Наглядное отображение результатов в кратком и детальном виде поможет быстро найти интересующий фрагмент.

5 стартмани

19.09.2018    9495    15    TSSV    14       

Подборка программ для взаимодействия с ЕГАИС Промо

ЕГАИС (Единая государственная автоматизированная информационная система) - автоматизированная система, предназначенная для государственного контроля за объёмом производства и оборота этилового спирта, алкогольной и спиртосодержащей продукции. Инфостарт рекомендует подборку проверенных решений для взаимодействия с системой.

Помощник корректировки остатков ЕГАИС в небольшом магазине. Розница 2.2

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Рестораны, кафе и фаст-фуд Россия УУ Розничная торговля Абонемент ($m) Обработка документов

Данная обработка упрощает корректировку остатков алкогольной продукции небольшого магазина, где предполагается передача всей продукции в торговый зал сразу после приемки.

5 стартмани

08.09.2018    19148    80    asdfgcom    46       

Загрузка файлов/картинок/изображений/фото номенклатуры PRO

Инструменты и обработки Программист Пользователь Внешняя обработка (ert,epf) v8 v8::УФ Розница УНФ УТ11 Россия Оптовая торговля Розничная торговля Абонемент ($m) Управленческий учет (прочее)

Пожалуй, самая многофункциональная обработка для пополнения каталога. Сопоставление изображений с номенклатурой по артикулу, коду и подстроке; обновление/замена, удаление фото; установка основного изображения по расширению или по любой части наименования файла. Информация о файлах и результаты сопоставления с номенклатурой отображается в таблице. Для каждого изображения есть возможность предпросмотра. Процесс загрузки картинок отображается через прогресс-бар.

1 стартмани

03.08.2018    12020    74    zannv    32       

Перенос документов, остатков и справочников КА 1.1 => КА 2 / УТ 11. Обновлено до КА 2.4.12.х и УТ 11.4.11.х! Промо

Более 130 компаний выполнили переход на КА 2 или УТ 11 с помощью нашей разработки! Позволяет перенести не только остатки и справочники (как типовая обработка), но и документы за нужный период времени. Предоставляем техподдержку, оперативно исправляем замечания, выпускаем обновления при выходе новых релизов программ 1С. Вы можете проверить разработку до покупки: сделаем бесплатный тестовый перенос из вашей базы КА 1.1 и предоставим доступ к базе-результату через веб-клиент!

29700 руб.

Класс-обработка “Работа с картами Яндекс”

Инструменты и обработки Программист Конфигурация (md, cf) v8 Абонемент ($m) Разработка внешних компонент WEB

Как показать точку или маршрут на карте Яндекс. Как получить координаты по строке адреса (геокодирование).

1 стартмани

01.08.2018    14551    149    RSConsulting    14       

Распознавание лиц (off-line). Демонстрационная база.

Инструменты и обработки Системный администратор Пользователь Руководитель проекта Архив с данными v8 Абонемент ($m) Разработка внешних компонент

Распознавание лиц входит в нашу жизнь стремительными темпами, бизнес стремится за событиями. В публикации находится описание и пример использования нейросетей для распознавания лиц.

1 стартмани

17.07.2018    11950    75    nomadon    45       

1C:Предприятие для программистов: Запросы и отчеты. Второй поток. Онлайн-интенсив с 17 марта по 16 апреля 2020 г. Промо

Данный онлайн-курс предусматривает углубленное изучение языка запросов и возможностей системы компоновки данных, которые понадобятся при разработке отчетов, работающих на платформе “1С:Предприятие” в рамках различных прикладных решений. Курс предназначен для тех, кто уже имеет определенные навыки конфигурирования и программирования в системе “1С:Предприятие”, а также для опытных пользователей различных прикладных решений, которые используют в своей работе отчеты разного назначения.

6500 рублей

ЕГАИС 3 Контролёр для 1С:Розница

Инструменты и обработки Системный администратор Пользователь Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) Россия УУ Android Розничная торговля Абонемент ($m) Терминал сбора данных

Оградите себя от рисков отзыва лицензии на торговлю алкоголем, штрафов и блокировок в ЕГАИС. Проверяйте поступающую алкогольную продукцию помарочно на соответствие ТТН ЕГАИС v3 перед тем, как подтвердить получение и принять её на баланс в ЕГАИС. С 01.07.2018 начинается переход ЕГАИС на помарочный учет алкогольной продукции на всех стадиях товародвижения, начиная от производства или ввоза на территорию России, до реализации в розничной торговле, т.н. "ЕГАИС 3.0". В типовой Рознице уже появилась обработка для контроля поступивших акцизных марок на ПК. Предлагаю ознакомиться с мобильным решением. Контроль производится в Android приложении на ТСД или на обычном смартфоне.

1 стартмани

13.06.2018    12281    16    kuld    30       

Пробитие чеков через ККМ в офисе (для курьеров)

Инструменты и обработки Пользователь Расширение (cfe) v8 v8::ОУ Розница УТ11 Россия БУ Кассовые операции Розничная торговля Абонемент ($m) ККМ Фискальный регистратор

Предлагается интеграция 1С с ККТ СтарРус. Поддерживается одновременная работа с разных рабочих мест. ККТ СтарРус работает как сервер, и принимает команды через API по http-протоколу, что позволяет пробивать чеки через центральную базу 1С для интернет-магазина и для курьеров.

1 стартмани

07.06.2018    21532    27    Kutuzov    12       

Базовый курс по управлению ИТ-проектами. Курс проходит с 26 февраля по 22 апреля 2020 года. Промо

Отличительная черта курса - органичное сочетание трех вещей: 1.Теория проектного управления (PMI®+Agile Alliance+Российские ГОСТ+Методологии от 1С); 2. Опыт внедрения продуктов 1С (опыт франчайзи и успешных компаний + тренды Infostart Event и Agile Days); 3. Разбор реальных проблем и рекомендации экспертов по проектам слушателей. Мы будем фиксироваться на тех инструментах, которые реально оказываются полезными в практике руководителей проектов внедрения. Ведущая курса - Мария Темчина.

от 11000 рублей

Корректировка остатков ЕГАИС для 1С:Розница/УТ 10.3 - альтернативный вариант

Инструменты и обработки Бухгалтер Внешняя обработка (ert,epf) v8 Розница Розничная и сетевая торговля (FMCG) БУ Розничная торговля Учет ТМЦ Абонемент ($m) Обработка документов

Обработка корректировки остатков ЕГАИС для 1С Розница версии 2.2.7/2.2.8/2.2.9/2.2.10/2.2.11/УТ 10.3.47.ХХХ-48.XXX-49.XXX-50.XXX раздельно по маркируемому/немаркируемому алкоголю + создание документов постановки/списания по пересортице.

1 стартмани

02.06.2018    22620    334    independ    242       

INFOSTART MEETUP Kazan. 13 марта 2020 г. Промо

Инфостарт продолжает путешествие по России. Следующая остановка - Казань. Тема мероприятия - управление и технологии автоматизации учета на платформе "1С: Предприятие". Ждем всех: докладчиков и участников! Стоимость участия - 5 500 рублей. Цена действительна до 30.01.2020

5 500

Tool1CD Beta в деле

Инструменты и обработки Программист Компонента, плагин (dll, vbs,..) v8 Абонемент ($m) Разработка внешних компонент

Пс, парень! Не хочешь немного сырых байтов?

1 стартмани

09.05.2018    19553    29    baton_pk    26       

Yep Cart. Пишем интернет-магазин на http-сервисах OneScript

Статья Программист Конфигурация (md, cf) v8 УУ Оптовая торговля Розничная торговля Абонемент ($m) OneScript

В статье описана демонстрационная конфигурация, реализующая простейший интернет магазин на http-сервисах OneScript, интегрированный с 1С:Предприятие.

1 стартмани

16.04.2018    11864    15    blackhole321    33